Having trouble with a memory card

Discussion of photography and videography techniques, equipment and technology, and links to personal railroad-related photo galleries.

Moderators: nomis, keeper1616

Having trouble with a memory card

Postby Lackawanna565 » Mon Apr 08, 2013 11:13 pm

This past July I went to California. Did some railfanning out there. When I got home. The one memory card was giving me problems. Couldn't see any of the photos or videos. And it won't upload anything to the computer. Someone looked at the card for me and said he couldn't get the card to power up. Something like that. He thinks static electricity got to it. I think it was from when I was laying in my bed on the way home on the train. Is there anything I could do to get the photos and videos back? I don't want to give up on it and throw the card away. If it is useless. It was my first time out to California and seeing the trains out there.

Thanks for any help.
User avatar
Lackawanna565
 
Posts: 289
Joined: Mon Jul 31, 2006 11:02 am
Location: Kingston, PA

Re: Having trouble with a memory card

Postby MEC407 » Tue Apr 09, 2013 2:59 pm

I would suggest contacting the card manufacturer. Some of them offer free programs you can download to help rescue files that have been accidentally deleted or files that have become corrupt.

There are also some good suggestions here: http://www.pentaxforums.com/forums/acce ... -card.html

But definitely contact the manufacturer first and see what they recommend.

In the meantime, don't put the card in a camera or in a card reader, as this could potentially make matters worse.
MEC407
Moderator:
Pan Am Railways — Boston & Maine/Maine Central — Delaware & Hudson
Central Maine & Quebec/Montreal, Maine & Atlantic/Bangor & Aroostook
Providence & Worcester — New England — GE Locomotives
User avatar
MEC407
 
Posts: 10695
Joined: Thu Mar 11, 2004 8:15 pm


Return to Photography & Video

Who is online

Users browsing this forum: No registered users and 1 guest